JetBrains:IntelliJ 项目已迁移到 Java 17,新版 IDE 将强制要求

2022-08-21 15:20IT之家 (汪淼)

IT之家 8 月 21 日消息,JetBrains 于 8 月 18 日发布公告IntelliJ 项目的源代码最近迁移到了 Java 17

官方表示,他们仍然编译了一些模块以兼容旧的 Java 版本,因此可以支持在这些版本下运行用户的项目。但是,现在大多数平台和插件模块都使用 Java 17,而即将推出的所有基于 IntelliJ 的 IDE 的 2022.3 版本都需要 Java 17 才能启动

对于开发者来说:

  • 如果你是开发插件的,则可以使用 Java 17 中的新语言功能和 API,但前提是 plugin.xml 中的 since-build 属性设置为 223。

  • 如果你的插件分发需要在多个版本的 IDE 上运行,例如 2022.3 和 2022.2,则必须继续使用 Java 11。

  • 如果你要编译 intellij-community 项目,只需调用 Build Project 操作。IntelliJ IDEA 会建议你自动下载 JetBrains Runtime 17,并将其设置为项目 JDK。

IT之家了解到,基于 IntelliJ 的 IDE 早在去年就支持了 Java 17,而本次官方项目迁移,意味着新版本将强制要求使用 Java 17。

文章价值:
人打分
有价值还可以无价值
置顶评论
    热门评论
      全部评论
      一大波评论正在路上
        取消发送
        软媒旗下人气应用

        如点击保存海报无效,请长按图片进行保存分享